Heated mirrors enigma

steve@cromford

A2OC Donor
I have retro-fitted heated mirrors to both of my A2s.
Both work ok on the passenger sides, neither work on the drivers sides.
I've swapped the mirrors over to check they actually work, and they do.
Seems strange to have a wiring problem on the drivers side on both cars!
Any ideas?
Thanks
Steve
 

Darren C

Admin Team
I have the same issue. Tom tested the continuity when here fitting my BOSE last week. Wiring and heated mirror element were fine. Problem is likely the control module in the door at fault and giving a spurious reading. I'll look to find a replacement in due course to test the theory.
 

steve@cromford

A2OC Donor
Will do Jeremy
By the way, I've fitted the window regulator / control module to "Sophie" and it worked a treat. Thanks
So I have the old one a spare. It's a passenger side, but I suppose I could connect it to try it out?
 
Will do Jeremy
By the way, I've fitted the window regulator / control module to "Sophie" and it worked a treat. Thanks
So I have the old one a spare. It's a passenger side, but I suppose I could connect it to try it out?
Unfortunately they're "sided", I can't remember which one you had now.
 

steve@cromford

A2OC Donor
I assumed as much
I had the passenger side from you.
I'll have a look at them over the weekend and let you know.
Thanks
Steve
 

cheechy

A2OC Donor
Probably a dry solder joint. I replaced my passenger side one on Monday with exactly the same symptoms and all working fine now. Seems a common issue now with the ageing electronics
 

audifan

A2OC Donor
Mirror plug not the best design. I wrap tape a turn around the plug. Fit the plug to the controller, then while holding the plug tightly in the controller run the tape tightly up the side of the controller. Have seen these plugs with cracked corners as easily damaged when removing the door card.
 
Top