How can i check if webesto heater is working

Johnboy374

New Member
Good evening can anyone please advise me how to check if my webesto heater is working as it did not switch on this morning at 5 deg i thought it would.
 

steveb

A2OC Donor
The exhaust is in the undertray O/S/F , very hot gasses if it's working. Do you have econ switched on ? if you do the webasto will not work.
 

Johnboy374

New Member
Thanks for your advise the econ switch is off and the exhaust from heater is cold it was working last year as i could hear it running and gases from the exhaust is there no way of checking it other than waiting for the temperature to fall below 5 deg.
thank-you all for your help.
 

Proghound

Admin Team
It shouldn't even take 5 degrees for it to come on. AFAIK it's specced for 7 degrees or lower, mine's certainly on at 7 degrees. Unfortunately I think yours may indeed have stopped working.
 

Robin_Cox

Member
In my Webasto-equipped car (not having had the conditions previously, and the other A2s don't have one), I've had 2 mornings this week (4 degrees and 1 degree external temp indicated) where within a couple of seconds starting up with climate on 20 degrees there was a noticeable hum that I've never heard before rather like a low-pitched coffee grinder audible from somewhere in front of the pedal box (when in the car), and a minute or so after starting up when idling at the end of the drive, there was a visible plume of steam coming from somewhere under the drivers' side wheel arch forward end (basically emanating from under the fog light on that side). The exhaust isn't actually screwed into the undertray mounting point so I suspect I need to make sure that it isn't cooking something untoward. I have to say I didn't find the warming-up time noticeably quicker, but the fuel gauge has dropped more for the same mileage than it did last tank (not unexpectedly in the cold), but maybe I need to figure out ways to use it effectively.

Ps. - I recently found a tutorial on here about performing the VCDS test for the Webasto but have mislaid the piece of paper. Try searching for threads with Webasto as the search term. Auxiliary heating diagnostics & actuator test come to mind but I don't have my notes on this here. All I remember was that you don't run it for long to avoid overheating it as there isn't a working pump in the auxiliary heater system unlike some 3rd-party added Webasto systems.
 
Last edited:

Proghound

Admin Team
There's one turned up on eBay this morning. A bit high at the Buy it Now price but you could make an offer.

 

Jellybean

Admin Team
Part Numbers?
Need to get new expansion tanks for my A2's.
Anyone know the Part Number?
Also need a hose for my FSI. Marked on image below. Preferably just the one elbow from T piece to the engine, rather than the complete engine to radiator hose.
Anyone know the Part Number?


Sent from my SM-N960F using Tapatalk
 

Edwrai

Member
Part Numbers?
Need to get new expansion tanks for my A2's.
Anyone know the Part Number?
Also need a hose for my FSI. Marked on image below. Preferably just the one elbow from T piece to the engine, rather than the complete engine to radiator hose.
Anyone know the Part Number?


Sent from my SM-N960F using Tapatalk
Those retaining rings on the pipes if they are like the ones I have removed are sealed rings with no way to take off without cutting, so you may need the whole assembly or cut them off and jubilee the new pipe on.

The other this the one that is a part of the quick connector for the top radiator hose?


Sent from my iPhone using Tapatalk
 

Catnip64

A2OC Donor
Part Numbers?
Need to get new expansion tanks for my A2's.
Anyone know the Part Number?
Also need a hose for my FSI. Marked on image below. Preferably just the one elbow from T piece to the engine, rather than the complete engine to radiator hose.
Anyone know the Part Number?

Sent from my SM-N960F using Tapatalk
You should be able to find the details here:
 

Rickmeister

Member
On our car with an OEM heater, it needs more than a certain amount of fuel in the tank, or it wont run.... Is this teh case with your A@?
 

Johnboy374

New Member
Update on my webasto heater.
last couple of days outside temp 4 degrees but heater did not come on. can anyone tell me where the sensor is that tells it to switch on or is there anyway to make it come on .
 

damadgeruk

Admin Team
Update on my webasto heater.
last couple of days outside temp 4 degrees but heater did not come on. can anyone tell me where the sensor is that tells it to switch on or is there anyway to make it come on .
The temperature sensor is just behind the front bumper though the webasto uses the same reading as the dash IIRC. Diagnostic scan is probably your best bet rather than trying to fix it blind.
 

kp 115

A2OC Donor
Update on my webasto heater.
last couple of days outside temp 4 degrees but heater did not come on. can anyone tell me where the sensor is that tells it to switch on or is there anyway to make it come on .
Have you bled the hose to ensure you have not got an air lock in the Webasto water pipe
Small bleed valve/ nipple on hose under brake fluid reservoir, this fixed mine when I carried out a full fluid change recently,
Sensor for Webasto is in the lower grill use ice pop or ice cube to simulate frost/ low temp
Situation.
Hth
Keith
 

Au2ro

Member
I have had an issue with my Webasto never coming on since I got the car .
One of the first things I did wen I got it all those years ago was drain and fill the coolant system - and that has been done a few tines since then, never knowing about the Webasto bleed screw.
I did try bleeding and the ice cube trick today, but the Webasto still never came on even though it thought that it was 5 degrees C.
I was advised to get a new glowpin/plug from a scan in the summer so I will be getting one soon to try that.

I found this link for a kit - Webasto Thermo Top E/C/P/Z glowpin kit | 9017813B But it states
"This glow pin repair kit only applies to heaters TT-E, TT-C, TT-P, TT-Z
manufactured from >2004."
and mine is a 2002. I will ask the supplier if they have the same kit for 2002 model.
 
Top