Sunroof not working after mod :(

johnyfartbox

A2OC Donor
πŸ˜‚, never sold any seats Mr Angry 😑.
Me and the lad tried for a good while but to no avail.
Wouldn't care, it was working fine yesterday and suddenly its stuck shut. Better than open I spose.
I've come to the conclusion it's gonna stay shut πŸ˜‚ πŸ˜‚ πŸ˜‚
 

audifan

A2OC Donor
Disconnect the battery for half an hour. Best to leave the hatch open if you can and REPLACE fuse 8 with a known good fuse. Reconnect battery and see what happens. BTW how well charged is your battery?
 

Mr Angry

A2OC Donor
Must have you confused with someone else then johny lol

The battery was/has been flat but i've been starting it up every day and it's fine now. When i do test the sunroof i make sure the engine is running. I tried disconnecting the battery yesterday but it made no difference :/
 

Kleynie

A2OC Donor
πŸ˜‚, never sold any seats Mr Angry 😑.
Me and the lad tried for a good while but to no avail.
Wouldn't care, it was working fine yesterday and suddenly its stuck shut. Better than open I spose.
I've come to the conclusion it's gonna stay shut πŸ˜‚ πŸ˜‚ πŸ˜‚
Sorry to hear that. Sounds like you need to visit Kleynie Towers now!
 

johnyfartbox

A2OC Donor
πŸ˜‚ Nah bud, anyway, it's not mine, it's the lads, at least it looks the part now and not like it's been rolled over.
Thanks for the invite though.
 

depronman

A2OC Donor
This sounds very much like a motor failure
There are some sensitive electronics inside the motor that do the calibration and learning side of the motor
The fact that it shuts when manually opened is symptomatic of the calibration side of the motor unit having failed
The switch is a mechanical thing and very unlikely to have failed
The wiring is ok because the motor is moving in one direction
I made up a test loom so that I could run the oss when I had it out of the car, it uses the original switch to control motor direction stop start I can post the wiring if you you are interested but you will need to have a spare blue connector that plugs into the oss motor

However as I said this is almost certainly a oss motor failure. I have one for sale in the market place it’s tried and tested and works perfectly (I found I had three spare oss motors which is a little excessive)

Best of luck with the oss fix
Paul


Sent from my iPhone using Tapatalk
 

johnyfartbox

A2OC Donor
Can I just ask something, this calibration task, will this only work if the OSS is working as it should?
In other words, if it is a broken OSS where one cable is no longer fixed to the bracket for example, the calibration simply cannot be done surely.
 

depronman

A2OC Donor
The calibration just learns the shut point of the oss
So if a single cable is working it will still hold steady at the shut point )unless the cable skips the motor teeth which is another ISS failure point)
Assuming you don’t get the click of death from the oss then after around 10seconds of holding the switch in the close position the motor will learn the closed position
The motor knows how many turns to do from closed to open hence it only needs to know the closed position
This is the reason that recalibration needs to be done if you use the Allen key to manually move the oss. When manually moving the oss with the Allen key you also need to not open it too far as the motor knows where the fully open position is by the number of turns it makes from fully closed

Paul


Sent from my iPhone using Tapatalk
 

johnyfartbox

A2OC Donor
Thanks Paul, that explains why the lads wont calibrate then, on pressing the button to close the OSS while its in in the closed position after about 10 seconds you can hear it click click clicking, quite loud. It then stops and on pressing the open button (I can hear a faint click) I then press the open button and it manages to lift the first glass panel but stops and gives up.
I can wind it back further using the allen key but have to use it to close it.
We gave up after four or five goes and left it shut πŸ˜‚
 

depronman

A2OC Donor
So the clicking is the cable riding over the teeth in the motor pinion
It’s in need of a refurb when it gets to this stage. Beat leave it shut if your not getting it refurbished

You have an official BSS in the A2.


Sent from my iPhone using Tapatalk
 
I made up a test loom so that I could run the oss when I had it out of the car, it uses the original switch to control motor direction stop start I can post the wiring if you you are interested but you will need to have a spare blue connector that plugs into the oss motor
@depronman - it might be a good idea to post up the wiring to test the motor/roof anyway, then Cameron can perform a test and confirm the results.

Cheers
Jeff
 

Mr Angry

A2OC Donor
Paul can you show a picture of your setup for testing my motor? Not sure if I will have the materials to do it but all I can do is try :)
 

depronman

A2OC Donor
Here you go





Brown wire is earth the other two are connected together and are +12 volts
The blue connector plugs into the oss motor and the fly lead of the oss motor plugs into the switch (out of an oss light switch assy)
The lead from the switch is unused

Hope this helps

Paul


Sent from my iPhone using Tapatalk
 

Colin 540

A2OC Donor
Clicking almost always means a broken roof. You will need to try and calibrate it to confirm, hold the close button for the roof for 10 seconds, it should click, then make no noise for about 9 seconds, and then click again, but quieter. If it keeps clicking while you do this, it's broken.
Sorry to hijack this thread but -
Just done this test on my oss and had the results you have posted above
@Kleynie
Not opened my oss for a year now as I experienced a clunk on closing from tilt position.
When looked at the oss from outside of car the tilt was slightly open a gentle push and it closed.
Never attempted to open again my thoughts was broken sky I have now.
Should I open it ?
 

Kleynie

A2OC Donor
Sorry to hijack this thread but -
Just done this test on my oss and had the results you have posted above
@Kleynie
Not opened my oss for a year now as I experienced a clunk on closing from tilt position.
When looked at the oss from outside of car the tilt was slightly open a gentle push and it closed.
Never attempted to open again my thoughts was broken sky I have now.
Should I open it ?
I wouldn't to be honest, although if you do want to, it is possible to close it again with the Allen key under the reading light.
 
Top